Year/Make/Model: 2011 Hyundai Santa Fe Limited AWD Mileage: 180,000 Transmission: Automatic (Current) OBDII Trouble Codes: piston 4 misfire Previous Warning Lights: ->Solid & Flashing Check Engine ::…

RochesterNY_Engineer

Year/Make/Model: 2011 Hyundai Santa Fe Limited AWD
Mileage: 180,000
Transmission: Automatic
(Current) OBDII Trouble Codes: piston 4 misfire
Previous Warning Lights:
->Solid & Flashing Check Engine :: only flashed once, solid for weeks on and off
->ABS :: on/off for weeks at a time
->Tire Pressure Warning :: goes away within minute of starting

This is my dad's old car. He would drive it back and forth between NJ and NYC for 7 years. No accidents or damage.

My main question: can you figure out what the problem is? If so, what's the fix? If not, what the best way to sell it given its state?


Issue Timeline:

2 years ago:
-ABS and solid check engine lights would come on and off every now and again.

1.5 year ago:
-Wouldn't start up. AAA changed my battery. Started right up.
-Sometime after this ABS light was solid and stayed this way for a while.

1 year ago:
-ABS and/or Check Engine light would be solid on/off randomly
-Shifting between park, drive, reverse, etc began to lock up sporadically (and then permanently). Needed to use shift lock release to override it.
-Car started making some noises on cold starts.
-The noise wasn't too bad then. It's much louder today. See video below to hear noise
-Brought to mechanic: They didn't know exactly what was wrong and warned me digging around could be expensive and they might not find anything.

Recently:
-ABS light suddenly turned off a month ago and shifting worked without shift lock release override for a while. As of a few days ago it's locked back up again.
-Car makes a very loud sound on cold starts lasts for ~5 seconds (video below)
-Car dumps a ton of exhaust upon this first start up. It's a white/grey smoke and lasts for 30 seconds. Has a strong smell. (video below)
-Upon acceleration I hear a slight vibrating sound which seems to be coming from the very front of the car. Almost sounds like my license place is shaking. But goes away eventually.
-I've had trouble starting my car 3-4 times as of 3 weeks ago. I hear 1 'click' and then nothing. By the time I get AAA on the phone, and the car will decide to start.
-A few week ago I was driving and all of the sudden the check engine light was flashing. Pretty severe vibration in the car even in idle. I didn't drive far.
When I restarted it, the check engine was solid with no vibration in the car. This seemed to produce the piston misfire code. Drove a few days after and check engine light disappeared.
-Recently I've noticed the AC has a very gasoline-y smell.

Cold Start Noise & Exhaust Dump: https://drive.google.com/file/d/1QymyYZ2AwSqQUVtrAt6itJ4vfomKfC8I/view?usp=sharing

THANKS FOR EVERYTHING, YOU'RE A LIFESAVER!