Omrcampos2

Hello Scotty,
I have a Tacoma 95 Extended Cab 2.4L manual trans and I have been having some issues with it since I got it from a second owner.

The truck starts perfectly on a cold start but it cranks and it won’t start until maybe the 3rd or 4th try of me cranking the engine on a hot start. I can park it after driving it and when I return to start it a few minutes later is when I get the problem.

I have tried to do the work my self but my knowledge is very limited, I am a fan mechanic not a mechanic at all, I think a real mechanic might get offended by using that word while describing my skills in that area if they heard me. I have also taken the truck to a couple of shops and they have not been able to diagnose the problem.

I have changed all kinds of parts from the electrical side (I think this should only be an electrical or fuel issue). I have also replaced the fuel pump, fuel filter, fuel thermostat, fuel regulator, etc....

What do you suggest I do? I don’t mind taking it to a shop but unfortunately I have taken it to 2 of them already and I had to pay for the diagnostic without the solve for the issue.

Sorry for the super message, I hope you can understand, I just don’t know what else to do with my truck.

Thank you for your time

Comments (2)
No. 1-2
Omrcampos2
Omrcampos2

You think I should pressure test the fuel pump even though it not even a year old? I replaced it last year but I bought an aftermarket part not the OEM, I was told that it might not be good.

Okay, I will work on that, thank you for taking the time to respond, I honestly figured you were to busy to answer my question.

Thanks a bunch, good day.

Scotty Kilmer
Scotty Kilmer

Editor

Try pressure cleaning of fuel injectorsn and Pressure Test fuel pump