Scotty PLEASE HELP! ?!?! On my Fusion we have charged the freon good guage readings ... it was…

Bl3SS3dM0MbYChRiSt

Scotty PLEASE HELP! ?!?! On my Fusion we have charged the freon good guage readings ... it was blowing cool through the driver side cold and passenger side was warm it did work for a week when it wanted to have changed pressure switch sensor & evap sensor can engage clutch with relay jump but no cool air ... what do you think this sounds like is that another sensor switch that has opened and needs to shut in order to tell it to come on ? an electrical problem another sensor switch maybe :-( TURNING ON A/C IN CAR CABIN DOES NOT ENGADE COMPRESSOR AND THE WEEK IT DID IT ONLY HAD SLIGHT POWER IT FELT LIKE HAD TO CRABK TO FAN HI= 4 TO REALLY COOL OFF !!! please help
Bl3SS3dM0MbYChRiSt
Bl3SS3dM0MbYChRiSt
26 mins
07 Ford Fusion SE 203k 4cyl 2.3L

Comments (3)
No. 1-3
Believe231
Believe231

No more codes? Are you sure the compressor just simply isn't worn out?

Bl3SS3dM0MbYChRiSt
Bl3SS3dM0MbYChRiSt

Thankyou so much ! Had scanner on it read evap temp sensor (hi circuit ) removed dash replaced now no cool air when jumping relay to kick compressor on ....

ScottyKilmer
ScottyKilmer

Editor

Drivers side cold and passenger warm is a failure of the actuator system on the passenger side. low refrigerant would make the passenger cold and driver's warm. Odds are you have more than one problem, both a leak and an actuator door problem. Takes a pro with a dealer level scanner to mess with that complex HVA system