Random service lights going on and off like crazy!

Timeformyself

Hi Scotty, I have a 2005 Sienna LE with 195,000 miles. I had my front brakes serviced at a Toyota service center. When the car was returned to me, the check engine, tire pressure, brake, and ABS light was on. I immediately told the tech on site, they took the car and return it to me 15 min. later. All the service lights was gone, but 5 minutes after I drove away, check engine and tire pressure light came back on. I contacted the tech immediately from my cell phone. He asked that I bring the car back. They said it's the vehicle speed sensor A, p0500. Toyota center said it was just a coincidence and changing the front brake would not have caused the problem. I took the car to another mechanic who drove the vehicle and all the wheel reading is the same, even though he got code, the reading doesn't show which tire is having the issue. The lights are also intermittent. Sometime it's just the tire pressure light (nothing is wrong with the tire pressure), (tire pressure and engine light), (tire pressure, engine , and abs light), or all (4) (tire pressure engine, abs, and brake light.) What is going on with my car.? It's driving fine and my speedometer and rpm are not affected at all.

Comments (2)
No. 1-2
Timeformyself
Timeformyself

Thank you, I'll look into this possibility.

PulsarNXCAM
PulsarNXCAM

It is possible for the ECU to be wearing out, with age they loose their ability to properly detect problems in the engine and falsely cause codes when nothing is wrong. BEFORE REPLACING THE ECU BUY OR RENT A scan tool the one I use is by uscan it reads generic, OEM, live data charts, reads and,sea airbags, etc for about 80 dollars and can be used by your phone the problem you are having is common with vehicles with that mileage check your ecu's integrity and make sure its not loose wiring as this will cause on and off data sending get Scotty's help as well.