avtarnanrey

Hey Scotty

My 07 Toyota FJ Cruiser is giving me P0606 after I changed the tranny fluid, Headlight bulbs and cleaned the battery terminals.
I googled and found that this is commonly caused by bad O2 sensors.

Below is the Freeze Frame data from my cheap Ancel AD scanner. I'm a noob to identify if it is really an O2 Sensor issue or something else. Please help.

Thanks
Avatar Nanrey

Fuel system 1 status: CL
Fuel system 2 status: CL
Calculated LOAD value: 39.6%
Engine Coolant Temperature: 17C
Short Term Fuel Trim - Bank 1: -10.9%
Long Term Fuel Trim - Bank 1: 3.1%
Short Term Fuel Trim - Bank 2: -11.7%
Long Term Fuel Trim - Bank 2: 3.9%
Engine RPM: 1364/min
Vehicle Speed: 0km/h
Ignition Timing Advance for #1 Cylinder: 12.0 degree
Intake Air Temperature: 11 C
Air Flow Rate from Mass Air Flow Sensor: 13.94 g/s
Absolute Throttle Position: 18.8%
Oxygen Sensor Output Voltage (B1-S2) 0.115V
Short Term Fuel Trim (B1-S2) ---
Oxygen Sensor Output Voltage (B2-S2): 0.485V
Short Term Fuel Trim (B2-S2) ---
Time Since Engine Start: 26sec.
Equivalence Ratio (lambda) (B1-S1) 0.992
Oxygen Sensor Voltage (B1-S1): 3.249V
Equivalence Ratio (lambda) (B2-S1) 0.993
Oxygen Sensor Voltage (B2-S1): 3.246V
Commanded Evaporate Purge: 0.0%
Biometric Pressure 98kPa
Equivalence Ratio (labda) (B1-S1) 0.992
Oxygen Sensor Current (B1-S1): -0.03ma
Equivalence Ratio (labda) (B2-S1): 0.993
Oxygen Sensor Current (B2-S1): -0.03mA
Catalyst Temperature Bank 1, Sensor 1: 212.1 C
Catalyst Temperature Bank 2, Sensor 1: 212.1 C
Catalyst Temperature Bank 1, Sensor 2: 20.6 C
Catalyst Temperature Bank 2, Sensor 2: 20.6 C
Control Module Voltage: 13.769 V
Absolute Load Value: 25.9%
Fuel/Air Commanded Equivalence Ratio: 1.102
Relative Throttle Position: 0.0%
Absolute Throttle Position B: 51.4%
Accelerator Pedal Position D: 16.1%
Accelerator Pedal Position E: 31.8%
Commanded Throttle Actuator Control: 18.8%
Engine run time since DTCs cleared: 0d:01h:24m
Absolute Evap System Vapor Pressure: 99.015kPa