Im really hoping you can help me I have a 1996 Nissan Pathfinder with a 3.3 liter V6 I recently had to replace the distributor on a vehicle and now I'm getting a camshaft sensor circuit malfunction code P0340 intermittently vehicle cranks but does not start We have replaced the crankshaft sensor and ignition coil spark plugs and spark plug wires it is getting fuel but it still seems to be getting no spark do you have any suggestions? Also it is equipped with a security system I have attempted to reset the security system but on the front dash where the security indicator light is there is no illumination no blinking nothing at all? However the alarm does not activate there's no horn there no blinking lights nothing to indicate that the alarm system has been tripped other then the fact that it may be disarmed somewhat because the indicator light gives us no indication that it is working or not but there is no clicking in the relays that are for the security system there are no broken fuses there's plenty of power but still it continues to crank and will not start and intermittently gives the code P0340 camshaft sensor on a 96 Nissan Pathfinder with a 3.3 l V6

Comments (2)
No. 1-2
Ginakatabar
Ginakatabar

The distributor is good. I actually took the one outta my other pathfinder that is running perfectly. So i know thats not the issue. Ive been told to change out the doorlock on the drivers side so im going to try that and reset the system and see?

ScottyKilmer
ScottyKilmer

Editor

I would assume you got a crappy distributor myself. I ONLY use brand new ones, never rebuilt crappers. Got too many bad ones in the past. But if not, anti theft systems that break will do just that