I’m in desperate need of HELP!!! I’ve got a ek4 civic with a Honda Accord Mb6 b18c4 turbo conversion. It’s been running fine for a year until I hit a pot hole and my ecu came out of its holder…

Craig4cast

I’m in desperate need of HELP!!!

I’ve got a ek4 civic with a Honda Accord Mb6 b18c4 turbo conversion.

It’s been running fine for a year until I hit a pot hole and my ecu came out of its holder sending me into like a limp mode no power and could barely keep the revs. Then after an hour of sound like I’ve got 3 cylinder Looking at everything it started and was back to normal. I had the odd misfire but all seemed well

Christmas Day came and I drove fine to my mum and dads then 2 days later it wouldn’t start change the plugs rotor arm and cap

Still no luck change the coil and reset the ecu after it was out the car overnight and it started. It sounded rough so I revved it a bit and once it hit 2500 rpm it was fine.

After a decent drive it seemed under powered and clearly was I stopped for more fuel after being out for around 3 hours and it didn’t want to start After playing with the ecu and wiring it started.

I got it home and since then it hasn’t really started I got it going the next day but it sounded horrible, I literally tapped the ecu and the car shut off. Ok So the ecu obviously was damaged in the fall So after having a look at mine I realised a capacitor was burnt out so I replaced it but still no start.

so I got a new ecu today and It burnt out as soon as I went to start the car I smelt the smoke and undone the cover to fine smoke coming out of it.

Il add I had spark before and now I haven’t but the distributor is getting power I’ve changed everything inside the distributor Changed loads of sensors checked timing checked compression changed the plugs checked the relay etc because I got code 0 at one point haven’t had it since I removed the ecu.

I’m just really confused, I was going to get a new loom after getting someone to check the electrics

Has anyone ever had anything like this? Car cranks and everything seems to work but the engine starting But the main thing that’s confused me is the fact something has burnt out 2 ecu’s and one without even starting the engine

Please help!!!

Comments (2)
No. 1-2
Techsus
Techsus

Was the turbo conversion factory stock or performed aftermarket? If aftermarket, therein might lie the rub.

Craig4cast
Craig4cast

1997 civic 102k mileage Not sure on obd type has the 2blue plugs so I can’t scan properly but I get codes 12 14 16 18 changed the intake and the iacv cleaned injectors