I have a 2007 Nissan Murano SL and had a misfire on #4 and changed it for time being till I got…

Rameezomer

I have a 2007 Nissan Murano SL and had a misfire on #4 and changed it for time being till I got around to changing all and one day after I changed it had a random misfire . So I went and got new coil packs and spark plugs and as I begin to change them the two of the spark plugs had oil on them and the third just a hair bit so I opened up the valve cover and did not notice any leaks but I cannot tell if my tube seals are leaking can I get some help
Also being that I have oil in the tube how can I clean or do I have even have to clean it and it has 188kmiles

https://s3-us-west-2.amazonaws.com/maven-user-photos/ontheroadwithscotty/car-questions-and-answers/9YlBQywq20WP5ZZ11TPYBg/Oxlerf0gtEyqfRU5mBheww

https://s3-us-west-2.amazonaws.com/maven-user-photos/ontheroadwithscotty/car-questions-and-answers/9YlBQywq20WP5ZZ11TPYBg/fTzGsAtp5kO8poxa0ENtkw

Comments (5)
No. 1-5
Vladchan
Vladchan

Are you still on your original CVT by the way? Same vehicle but with 100K here

Rameezomer
Rameezomer

And another thing me.scotty the car did over heat from a busted radiator hose

Rameezomer
Rameezomer

also I had taking out the spark plug and it was clean before the oil got on them and re placed it with a new on and now it looks like the that as shown in the pic. So with that being said do you still think it’s the engine?

Rameezomer
Rameezomer

Thank you for the really fast reply

ScottyKilmer
ScottyKilmer

Editor

don't worry about those seals, engine is flat wearing out inside from the carbon build up evidence on some of the plugs . Just change plugs as they wear out and add oil, eventually engine will become undriveable