Hi Scotty I have a Nissan S Cargo that won't start, it has spark and has compression so that leaves…

GoJohnny

Hi Scotty

I have a Nissan S Cargo that won't start, it has spark and has compression so that leaves fuel.

It was running when I drove it into my unit which was a couple of months ago, when I say it was running, it was stuttering when it got hot (say after an hour of driving) but once I left it for 30 minutes it would drive fine again.

On that basis I wanted to fix the issue, I replaced the leads, plugs, coil, distributor cap, rotor arm, distributor module, air filter and welded the back box on the exhaust (can't get a new one anywhere, will have to get a custom one made at some point).

Once I did all that it was still starting.

I then decided to do a little body work, rubbing down scratches etc, I then decided to get it out into the sun to give it a really good clean and here's where the issue started, it just wouldn't start.

It turns over but won't fire, I hear bopping coming from the exhaust, like a little back fire I suppose, I also have a light on the dashboard which is the catalytic converter which is lighting up when I try to start it, could this be the issue?

When checking the spark plugs, they are bone dry although when I took the carburettor off to check it, there is a pool of fuel in the inlet manifold.

Is the inlet manifold blocked and should there be a pool of fuel in there? Is the catalytic stopping the engine running? or is that light only on because it's not been run for a while (well not run for long enough)

I'm not a mechanic but I tinker a lot but I cannot figure this out.

Please help?

Comments (4)
No. 1-3
GoJohnny
GoJohnny

Hi Scotty,

I took the oxygen sensor out and when I try to start the car, a blue flame come out of there with a bang but it still won't start. The bang was not a continuous bang but every 3-5 seconds roughly. I tried putting a little fuel down the spark plugs and the bangs were more frequent but still wouldn't start. I couldn't get the last spark plug out as my tool would not fit so I just did the first 3 at the time.

I've tried it with a new carburettor and that's made no difference at all. Could it be a blockage in the inlet manifold?

Thanks

GoJohnny
GoJohnny

Thanks Scotty I'll give that a go and let you know how I get on.