Hi Scotty and community, Back again with my Ford Escape 2002 V6 3.0 A recap of what happened, I started to have issues with idling, it will die sometimes when cold weather and cold start, I noticed…

BrandonK31

Hi Scotty and community,

Back again with my Ford Escape 2002 V6 3.0

A recap of what happened, I started to have issues with idling, it will die sometimes when cold weather and cold start, I noticed the EGR system was bypassed by previous owner ( vehicle was kind of a gift) now I got a mechanic connect the EGR valve and sensor, it was working fine for a few but then the idle will get worse even stalling, I took it to the shop and they carbon cleaned the EGR valve and throttle body, again it was working fine no issues but now is doing it again, I noticed there's still two valves blocked with bolts and they seemed to go to the DPFE sensor which I noticed it was connected with the electrical wire but hanging off the side, I disconnected it and noticed is beyond gone (see photo), anyhow, could this be the reason why idle is fine but then get worse? , no codes until I disconnected the DPFE which of course resulted in a p1401 issue, notice slight gas smell when cold but goes away when hot, also when hot there is no issue while idling, sidenote, sometimes it will crank but won't turn over for a while, then I will crank again and turn without issues

Thanks for the help, I'm kind of new with the mechanic stuff but seem to start getting the hang of it because of all the issues with my Escape

Comments (5)
No. 1-2
Scotty Kilmer
Scotty Kilmer

Editor

people block stuff off, then all bets are off on modern vehicles. Computer tries to compensate for confusing info it gets then and anything can happen

BrandonK31
BrandonK31

Sorry, photo didn't attached but is just to show how busted this thing was,