Hey scotty thanx again for the help. You helped me fix a problem with my 95 Silverado k1500 5.7 It…

Cody s

Hey scotty thanx again for the help. You helped me fix a problem with my 95 Silverado k1500 5.7 It turned out to be problem with someone installing after market security system. With the horn fuse in the truck would shut off and with it out it wouldn't turn off. But now I have a new problem. I hade the trans rebuilt. When it's cold outside if I start up the truck and go the trans slips from 2nd to 3rd and stays in third. When. I come to a stop it will still be in third when I take off. But after I drive like that for 10 min or so and the truck is worm I can turn truck off for 10 15 seconds so so and truck will shift perfect as it should. It's only when it's cold out. I have three codes 81,82, and 83. Short or open circuit in the 1-2 solenoid. Short or open in the 2-3 and 83 is the torque converter clutch solenoid open or short circuit. I changed the filter even know it was rebuilt because someone suggested it may be the problem. Seems electrical to me. I cleaned the transmission electrical connections with no luck. The solenoids should be new according to the trans shop but those are next in my check list. The trans is out of warranty. I feel like this have always been a problem but in the summer when it's warm in the morning here in sc I haven't noticed it at all. Thanx for any ideas at all

Comments (2)
No. 1-2
Cody s
Cody s

Thanks Scotty, I cleaned the connection to the transmission n wiggled the harness around and it's been good ever since.

Scotty Kilmer
Scotty Kilmer

Editor

if solenoids are new, someone already tried that. Then either wiring is bad or transmission computer module is shot if restarting fixes it a while