Hey Scotty I have an 2002 grand am gt I am having trouble accelerating If I push the gas at 0 mph it…

Dylan213

Hey Scotty I have an 2002 grand am gt I am having trouble accelerating If I push the gas at 0 mph it can pick up speed quick but looses power as rpms go up I have to left off the gas to shift (its an Automatic transmission) so i have to barley push the gas pedal to accelerate but its not fast so its a pain for the people behind me somedays the car drives somethly and somedays it doesnt and when it doesn't the car sounds VERY sluggish i have to almost floor the pedal to get it going the car jerks and just hums until I push the pedal hard speed kicks in but it still isint much power. so if i hit above 50mph it straightens out . A cold start it drives smoothly but when it warms up the car just randomly jerking and start to hums and I have to floor it. Another thing is I cant make it uphills the car doesnt have enough power to do it and I also cant reach above 60mph unless im going down hill but if i do reach like 75mph once I hit a flat road i can maintain the speed. I put in a new fuel filter new crank and cam shaft sensors new mass air flow sensor and checks the catalytic converter . I had an exhaust manifold gasket leak I but in a new metal plate and it stopped the squealing but before it was fixed it had more power but still didnt have alot but i could make it uphills fine and reach high speeds. Once I replaced the crank and cam sensors and exhaust manifold plate all at once the power dropped a lot and It sounded like it had a lot of back pressure the tranny didnt wanna shift so i unplugged the 02 sensor and it helped alot but still not much power it shifts on its own. I dont know what else it could be if its a bad sensor bad injectors or what and im tired of just guessing and wasting money. help would be appreciated!!