Hello Scotty. I have a problem with this car. It stopped driving, or at least it barely moves as if…

aghosheh

Hello Scotty. I have a problem with this car. It stopped driving, or at least it barely moves as if the transmission is not engaging. I can feel it engage but it revs and doesn't move forward much and it hesitates terribly. I pulled the codes and have it attached with this email. I have replaced the 2 year old VVT solenoids with 2 new ones and the ones I pulled out had metal shavings on them. This tells me the timing chain is rubbing and losing pieces. This is a common problem with this car. The engine however runs smooth and doesn't seem to be having any issues. It does have the oil consumption problem also which is why the P0420 is in there. and has been for the past 2 years. I add oil to it to keep it topped up and used Lucas oil to slow the consumption.

My question is why does the car run smooth even when the chain is breaking up? and why isn't it driving? Shouldn't it be like not starting if the timing is off based on the P0011?

My concern I don't want to pay $1000 quote to replace the chain and find out there is some other issue. Thank you in advance.

2 Pending Trouble Codes: P0016: Crankshaft Position - Camshaft Position Correlation Bank 1 Sensor A P0017: Crankshaft Position - Camshaft Position Correlation Bank 1 Sensor B

4 Permanent Trouble Codes: P0016: Crankshaft Position - Camshaft Position Correlation Bank 1 Sensor A P0420: Catalyst System Efficiency Below Threshold Bank 1 P0017: Crankshaft Position - Camshaft Position Correlation Bank 1 Sensor B P0011: "A" Camshaft Position - Timing Over-Advanced or System Performance Bank 1