Hello! I'm really excited to join this group. I was wondering if I could get some help with my 05 Lexus GX470. It has a little over 137k miles on it currently. I've noticed recently that when I release my foot off the brake pedal I feel a little engine stutter that I can feel through the pedal (it's really slight). I've also felt it when I release the brake pedal and press on the accelerator. It doesn't do it all the time but every once in a while. I have no check engine lights on at all either.

I've taken it to a mechanic and he has checked for pending codes as well and nothing. I've changed the spark plugs, air filter, oil filter, and even got a new oil filter and I can still feel it at times. He took my car out for a spin but said he couldn't feel anything weird or felt any kind of "misfire". I had a colleague of mine test drive it and I had to point out when I would feel for him to realize what I was talking about.

Any idea what it could be or what I could do?? I don't want to just throw money everywhere.....

Thanks!!!

Comments (6)
No. 1-2
arty1009
arty1009

@ScottyKilmer Thanks for getting back to me! Do you know if there's a way to check if that could be it other than having to change it and all of that? I just recently got the timing belt done along with the water pump also. I've invested a good amount of money into it recently and I just don't want to be throwing a good amount of change into it with something that won't help it.....=/.

Again, I really appreciate you getting back to me!

Scotty Kilmer
Scotty Kilmer

Editor

generally that's the transmission with minor wear. Change the fluid and filter and pray it helps some. Rebuilding them costs a ton