Hello, greetings from Malaysia.. I've been watching your videos since few years and its really amazing knowledge, thank you for all the sharings.. I have a problem now, since 3 weeks+ now my car still in workshop and almost going to be 4 weeks.. Im using Kia Spectra 1.6 DOHC 4 speed auto, and just did a full overhaul.. Took out the engine, clean everything from the oil pan, valve, valve springs, block, covers, everything etc.. Also took out the gearbox but just replace the seal.. So after the mechanic put together everything, car starts but the car is acting weirdly, sounds like jerking, coughing and from the exhaust pipe sounds like pop pop pop..

Previously before i did the overhaul, engine was smooth and exhaust pipe very silent because its a stock car.. My battery is new, spark plugs new, alternator is working fine, fuel injector works fine, air throttle body is fine, radiator is fine, fuel pump, water pump everything is okay.. But the mechanic said 1st piston no pressure, he check with pressure tool all the other piston has pressure on it but the 1st one drops alot.. At times he said, before put together everything engine is good but after fixing all the parts, pressure drops.. I've already change new gasket, new thermostat etc.. He even changed 2 new valve as he said it is a little bent (maybe like 3%).. Today he whatsapp me and asking me to change to a new thick gasket..

Do you knew what really is the problem? I did ask in all the other car clubs here, they suggest me that crankshaft should point upwards (at the line marking), left cam pulley for I - Intake and right cam pulley for E - Exaust.. Some even suggest that camshaft pin should point upwards.. I already told him all this info too, to which he replied saying he knows.. But then until now cant even fix it.. Its very difficult for me without a car.. Could u please share with me some knowledge? The car absolutely perfect, stock car and smooth but after full overhaul, it happens like this.. One thing i notice, when the car starts, it is coughing almost like gonna loose power, and you can hear in the exaust pipe pop pop pop backfiring and the rpm shows around 2000x..

Comments (2)
No. 1-2
KiaSpectra
KiaSpectra

Hello, my mechanic already fix the problem.. Now the car is normal and no problem at all.. The problem was the new gasket which i bought earlier is abit thin, so i buy again a thick gasket (4x times thicker) and everything normal now.. Thank you..

ScottyKilmer
ScottyKilmer

Editor

basically sounds like you got ripped off by a crooked or just plain bad mechanic. Pay another mechanic to check his work, especially the timing marks on the engine and pray he just put it together wrong and that now valves are not bent which that could do.