Fan of the channel... 07 chevy tahoe 2wd 5.3L. Bank1 bank 2 lean codes, evap leak, traction control... I've changed intake manifold gasket, throttle body gasket and cleaned it,purge solenoid, charcoal…

Texasbass254

Fan of the channel... 07 chevy tahoe 2wd 5.3L. Bank1 bank 2 lean codes, evap leak, traction control...
I've changed intake manifold gasket, throttle body gasket and cleaned it,purge solenoid, charcoal canister, vent valve. Every time I reset the engine light previous codes go away then come back in a couple of days idk.. as of now no evap codes just lean codes 1 and 2. I cleaned the fuel injectors and what I mentioned above.
Traction control is killing me driving me insane every time I put it in gear the engine or transmission kicks. So I cleaned in the throttle body changed the gasket as well as the intake gasket and it seemed to work the traction light and the engine light was of for one hole day then everything came back on not to mention my idle is hi every time my car is on idle or neutral 2000rpm..
What's next I'm lost

The only way I've got the traction control light off was by disconnecting battery all night but that has now come to a stop. I had success cleaning the throttle body and it worked for a day..

Just a DIY kind of guy dont know specific names to parts.

Could it be the wheel sensors or steering wheel sensor the one that's attached to the shaft under the steering wheel..
Also have replaced spark plug wires and the spark plug, new fuel pumps as well.

Comments (1)
No. 1-1
Scotty Kilmer
Scotty Kilmer

Editor

could be tons of stuff, but without a dealer level scan tool to do bidirectional testing of the system, it's just pure guesswork. Me, I'd live without trac, but find a really good mechanic if you want to find what's wrong with the trac