Dear Scotty, a big fan of your show. My issue is this- Own a 2006 Toyota 4runner 4wd, bought with…

REN-M

Dear Scotty, a big fan of your show. My issue is this- Own a 2006 Toyota 4runner 4wd, bought with about 90K Miles. Didn't know much about cars and used engine oil recommended by gas station mechanic rated 15w/50 (4X4) semi synthetic instead of 5W/30 SL. Used it consistently for over 5 years changing oil every 5K Miles. Mileage now at 158K. At 157K developed a slight tapping sound on driver's side of the engine, when turned on in the mornings & stops after a few minutes, now gone after recent Oil Change. Wasn't until the tapping sound & scarcity of the current engine oil used (15w/50 4x4) that I realised, I have been using the wrong oil grade. Silly me Need your advice as I want to switch back to the correct grade (5w/30) gradually from the next service starting with 10w/40 for a while. Been told by another "Mechanic" it's possible. Is it too late to make the change , as I am worried about oil leaks as explained in your videos from such actions. Also don't want to flush the engine based on you advice from another video. Am I stuck with current grade even though it is no longer available

PS live in the tropics, noticed slight combination of black stuff & fresh oil on left side of the engine recently but no oil leaks, also noticed sharp decrease in performance & gas mileage over time. Would greatly appreciate your view(s)

Comments (1)
No. 1-1
Scotty Kilmer
Scotty Kilmer

Editor

you can try changing back, but odds are there is some type of internal wear, like timing or valve wear