Aloha Scotty, I have a 2002 Impala; If i let off the throttle the engine immediately stalls,…

Subgasm

Aloha Scotty,

I have a 2002 Impala; If i let off the throttle the engine immediately stalls, however if i clear the codes it runs fine. I replaced each part for the many codes that appeared; IAC, TP, IAT, MAF, MAP, Heater hoses, Filter and belt....

When the vehicle does stall the first code is either; Mass Air Flow out of range, Throttle Position Sensor Faulted, Barometer Signal Too High. Even after i replaced sensors. However when i clear the codes, the car can run at idle just fine, Yesterday i let it idle for 4.5hours at the expense of half a tank of gas.

The only thing i can definitely say is that when the car will show the stall symptom, it will lug for a split second then after that short lag/lug/hesitation once i let off the throttle it will stall. I can crank the car but it will not hold idle, once i crank it i must apply throttle to keep it running, until i clear the codes then the car runs smooth. Last notation is my VSS code showed up, i did not attempt that yet due to my ignorance that I presume it only affects my stability control, traction, abs and cruise control.

What do you recommend i do? I tried to make sure I have ample and stable electric at the very least.

Comments (2)
No. 1-2
Subgasm
Subgasm

Appreciate your help. :) i will check those. Hahaha well i don't like worrying about getting stolen so i will keep the challenging chevy. Have a great day and again thank you!

ScottyKilmer
ScottyKilmer

Editor

either computer or wiring is bad. OR a combo of both. Those cars are junk at that age, you might considering getting a good used toyota