'95 Corolla Runs Rough After Tranny Swap

.Scotty,

For the past few days I've been working on replacing my transmission in my 1995 Corolla. Tonight as I was finally ready to turn the key for the fist time with the new transmission. The car started right away but I was greeted by a very rough idle, smell of fuel, smoke, and an exhaust leak also magically appeared.

I'm lost.. I attached a video so you can hear what it sounds like. I think it's running too rich for some reason.

I checked all the electrical connections and all the vacuum hoses. I should also mention that I pulled out the spark plugs right after it ran rough and they weren't very wet but not dry either.

It is also running on all cylinders because when it was running I pulled out one plug wire at a time to see if it was misfiring, and it ran rougher every time I pulled one out.

The idle you hear in the video is about 1200 rpm, the engine was cold.

Let me know if you need a list of parts that I removed during this process.

Thanks for any input, and appreciate your work as always .

Cristian

Comments
No. 1-4
ScottyKilmer
ScottyKilmer

Editor

It's often the simple things we overlook on a BIG job. Just remember, always be LOGICICAL

AutoFix
AutoFix

Got it!! Stupid me didn't notice the MAP sensor was unplugged this whole time.... I guess after three 12 hour days I was too tired to realize that. Thanks for your help and for telling me to double check EVERYTHING!!

AutoFix
AutoFix

Alright will do, I will double check everything as soon as I get the chance. Thank you very much for your response! It ran perfectly fine before, no issues whatsoever. Hopefully it's something simple and I forgot something.

ScottyKilmer
ScottyKilmer

Editor

ok, it sounds like crap. First check the exhaust for leaks, sounds loud too, and leaks will mess with air flow readings to the computer. IF it didn't run like that before you changed the tranny, somehow you messed something up. Check EVERYTHING you took off to make sure wires are plugged in, no wires are pinched between engine and tranny, and that you bolted all ground wires back on. good luck