2005 Toyota Sienna XLE. I found that the front passenger blend gate wasn't working. I disconnected it and managed to put the mix more towards warm without the actuator in place. My wife was tired of…

Joat1

2005 Toyota Sienna XLE. I found that the front passenger blend gate wasn't working. I disconnected it and managed to put the mix more towards warm without the actuator in place. My wife was tired of the cold air all the time. I have yet to replace it. That was about 2 months ago. I hope it's just the actuator. Anyway today as I was backing in to my driveway I noticed the cooling fans running high then low. My temperature gauge shows that the engine is running at the normal temp. Coolant is at normal level. As I parked I noticed the that the recirculate for the climate control was on. When I went to try and turn it off it would not unless I turned the A/C button off. I was puzzled and turn the van off. I looked on the internet and could not find anything. I went back outside after a while and the van was cooled a little. When I started it up everything ran fine until it came back up to temp then the recirculate turned back on again with the climate control in AUTO. One more time I tried and let the van cool down and started it back up only this time I left the climate control off. The cooling fans still come on when the engine reaches temp and they cycle low and high intermittently. There is no engine light on or anything to show that there is a problem. Is the van possessed? What do you think it is? Do I have more than one problem? By taking out the blend gate have I created the problem?