2001 mazda tribute lx 3.0 l v6 2wd.Ive been having problems with my mazda and ill tell all symptoms and parts installed . before replacing parts i hit a pothole on my front passenger tire. My check engine light started flashing everytime id accelerate. My speeds would reduce to 20-30mph and when stopped i would sometimes floor the gas just to get it up to 5mph. I went to autozone and had misfire on cylinders 2,5,&6 and other codes nothing major. Ill post a pic of the codes in another email. I changed all coils and sparks. Cranked it up still extreme idling and it would always cut off in reverse. So we checked everything and removed the upper intake manifold and resealed the gaskets..which got rid of the air intake leak..but then we put it back together then it wouldnt start. I bought a new battery because the old one kept dying and something was draining it. Then i bough a fuel filter and fuel pump. Then it crank but no start and yesterday august 4th i installed a crankshaft sensor tried cranking it and the new battery was dead ..so we charged it and cranked a few times and it was so close to catching until the battery went dead again. I was told to check the o2 sensor and catalytic converter. Im also going to clean all grounds and see if thats whats causing it to not start and also we did a code scan and it would not show any codes

Comments
No. 1-9
Nthomp210
Nthomp210

So it was starting and i drove it for 10 minutes and we replace the ETC sensor we believe the pcm is bad...

Nthomp210
Nthomp210

Hey scotty i got it to work we need to replace the fuses because the temp gauge on my instrument cluster would be below c or cold...so we checked the fuses inside and some arent lighting up with our test light thingie

Nthomp210
Nthomp210

The p0353 /353 might be the ignition connectors doung that...but im going with the p0117/118

Nthomp210
Nthomp210
Nthomp210
Nthomp210

Stories