1996 Acura TL 2.5 Rough Idle with AC turned OFF

Seany

Hi Scotty, I messaged you a few weeks ago about my '96 Acura TL that has 260,000 miles on it and has been experiencing hard starting, an intermittent rough surging idle, and difficulty accelerating uphill. A strange burnt smell is coming out of the tailpipe-- although the catalytic converter was recently replaced. I did as you suggested and replaced the fuel pump which helped the car to start up right away every time I start the vehicle (which is awesome, thank you for your help.) However the car is still having intermittent rough idle problems and intermittent acceleration issues. I changed the alternator yesterday because I noticed that something had been draining the battery even after I charged it. I also realized today that the surging idle issue stops if I turn my AC on full blast. What do you think could cause this? The car still has a code for a random misfire as well as a misfire on cylinder 3. Parts that have been replaced are: IAC valve, Fast Idle valve, spark plug wires, spark plugs, engine coolant temp sensor, PCV valve, alternator, catalytic converter, and fuel injectors, throttle body has been cleaned as well as the Mass Airflow sensor, the car passed a compression test, I removed the EGR replaced the gasket and cleaned it but am not sure if it is bad. I also noticed that the previous owner installed a throttle position sensor for the 3.2 model instead of the 2.5 so it does not entirely clip onto the electrical connector properly. I apologize in advance for writing a small novel and appreciate your help.

Comments (1)
No. 1-1
Scotty Kilmer
Scotty Kilmer

Editor

That old thing with that mileage could have a million things wrong with it. If I were you I would pay a guy like me to hook up is dealer level scan tool analyze all the live in historical data and go from there. Could be fuel injectors are worn out wiring problems all kinds of stuff